Cpanel product not available
Incident Report for Swizzonic
Resolved
All services on Cpanel are now up and running
Posted Feb 20, 2024 - 18:16 CET
Identified
We are experiencing problems on Cpanel platform, we are working on it to resolve the issue.
Posted Feb 20, 2024 - 17:32 CET
This incident affected: Hosting.